Page tree
Skip to end of metadata
Go to start of metadata

Virtual Environment Ubuntu screen is freezing randomly while using X2Go

Besides possible performance issues this can by caused by incompatibility of sound card. It can be solved by disabling audio support in X2Go - Session > Preferences > Media > Sound support

Closed remote proxy connection

It may happen that you can get following message when trying to connect to remote desktop. 

The remote proxy closed the connection while negotiating
the session. This may be due to the wrong authentication
credentials passed to the server.

Workaround 1

Initial workaround is to remove all opened sessions from your local ~/.x2go directory:

rm -f ~/.x2go/S-*

When connecting to server remember to terminate old session(s) and start a new session.

Workaround 2

If workaround 1 did not help:

  • repeat workaround 1 to avoid sessions mess
  • login to your x2go remote server and remove .Xauthority file in your home directory on the remote server:

    rm -f ~/.Xauthority
  • try X2go again

Workaround 3

If workaround 1+2 did not help:

  • repeat workaround 1+2 to avoid sessions mess
  • login to your x2go remote server and remove .ICEauthority file in your home directory on the remote server:

    rm -f ~/.ICEauthority
  • try X2go again

Wrong version or invalid session authentication cookie

Symptoms

Message in x2go log while connecting to server:

Loop: PANIC! The remote NX proxy closed the connection.
Error: The remote NX proxy closed the connection.
Loop: PANIC! Failure negotiating the session in stage '7'.
Error: Failure negotiating the session in stage '7'.
Loop: PANIC! Wrong version or invalid session authentication cookie.
Error: Wrong version or invalid session authentication cookie.

This seems to occur sometimes after reboot of server while some users were still connected.

Workaround

  • login to your x2go remote server via ssh and remove +re-create x2go sessions database file in your home directory on the remote server:

    rm -f /var/lib/x2go/x2go_sessions
    x2godbadmin --createdb
  • try X2go again

Inspired by https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=323

  • No labels